Pa-software community
Help, support and conversation
Welcome! ( login | register )
 
  Forum » ID3 Editor » MP3 file problems » unicode in command line
 

Pages: << prev 1 next >>
unicode in command line
This member is currently offline hc
Newbie


Member Level

Group: Members
Posts: 8
Joined: Feb 15, 2012

Add hc to your buddy list Send an email to hc Reply with a quote from this post Go to the top of the page

I bought a license of id3 editor yesterday. Unfortunately, today I found another bug(?).

When called from the command line in Windows 7 64 bits,

"C:\Program Files\ID3 Editor\id3edcmd.exe" -vn 2.3 -ti "AŮil" someFile.mp3

id3editor chokes at the non-7-bits characters. That is not a problem in the GUI, only in the command line. I tried several things like:

- setting codepages 437, 1252, 65000, 65001, or 28591
- launching the 64 bit version or cmd.exe and launching the 32 bit version of cmd.exe
- launching from unicode autohotkey.

The help states that -ti can be followed by any utext, where utext is unicode. Am I missing something?

++hc

Posted Feb 17, 2012, 3:07 pm
This member is currently offline jamesrae
Member


Member Level

Group: Moderators
Posts: 64
Joined: Dec 13, 2008

Add jamesrae to your buddy list Send an email to jamesrae Send a personal messsage to jamesrae Reply with a quote from this post Go to the top of the page

What kind of Unicode characters are used? As only UTF-8 is supported by the CLI.

Could you send an example of the text in a text document (to ensure there are no translation changes) to support to investigate.
.........................
James Rae
Pa-software support

Posted Feb 17, 2012, 4:45 pm
This member is currently offline hc
Newbie


Member Level

Group: Members
Posts: 8
Joined: Feb 15, 2012

Add hc to your buddy list Send an email to hc Reply with a quote from this post Go to the top of the page

The original file was produced with

Code:
1
lame --id3v2-only --id3v2-utf16 --tt "AŮil" --tn "05" test.mp3


The file was processed with a batch file that has the following content:

Code:
1
2
chcp 65001
"C:\Program Files\ID3 Editor\id3edcmd.exe"  -vn 2.3 -tr "5" -ti "AŮil" test.mp3


I tried with and without the first line. After your post, I have also tweaked the batch file to include correct utf-8 characters:

http://s14.postimage.org/eddc2d1r5/Command.png

The after and before:

http://s16.postimage.org/v95c3udrp/Tags.png

This is how they look in explorer

http://s15.postimage.org/6xkhzsz6z/Explorer.png

These issues do reproduce on both of my Windows 64 machines.

Where can I send you the files?

Posted Feb 18, 2012, 3:25 pm Last edited Feb 18, 2012, 8:03 pm by hc
This member is currently offline jamesrae
Member


Member Level

Group: Moderators
Posts: 64
Joined: Dec 13, 2008

Add jamesrae to your buddy list Send an email to jamesrae Send a personal messsage to jamesrae Reply with a quote from this post Go to the top of the page

We have been looking into the Windows CLI UTF-8 issue but so far there does not appear to be a problem. When we use the UTF-8 you gave, it results in the correct title. Perhaps the problem is in the batch file.

With regards to the zero, even using your settings with Lame we still do not get any issues, which suggests something is different in how we are setting this up and it would be better if you could send a copy of the track to support.

The support e-mail address can be found on the contact page.
.........................
James Rae
Pa-software support

Posted Feb 18, 2012, 8:43 pm Last edited Feb 19, 2012, 10:36 am by jamesrae
This member is currently offline DJP
Newbie


Member Level

Group: Members
Posts: 3
Joined: Jun 13, 2013

Add DJP to your buddy list Send an email to DJP Reply with a quote from this post Go to the top of the page

Hi, I have exactly the same problem although I envoke the command from a vb script, something like "id3edcmd -ar "dj tiŽsto" file.aif". It will write the tag as far as the dodgy character & no more.

The script works fine with FLAC & LAME tagging but not this.

Cheers.

Posted Jun 13, 2013, 8:58 am
This member is currently offline jamesrae
Member


Member Level

Group: Moderators
Posts: 64
Joined: Dec 13, 2008

Add jamesrae to your buddy list Send an email to jamesrae Send a personal messsage to jamesrae Reply with a quote from this post Go to the top of the page

Are you using 1.20.20? As this was an issue with a previous version but as far as we were aware it had been addressed.

Also, which versions of FLAC and LAME were you using?
.........................
James Rae
Pa-software support

Posted Jun 13, 2013, 9:52 am
This member is currently offline DJP
Newbie


Member Level

Group: Members
Posts: 3
Joined: Jun 13, 2013

Add DJP to your buddy list Send an email to DJP Reply with a quote from this post Go to the top of the page

I'm using the latest version 1.20.20.

lame.exe v3.99.5
flac.exe v1.21

Just to clarify all my files are .aif, not that it should make any difference. Strange thing is it will accept the non-standard characters in the filename but not write them in the tag. ie. <id3edcmd -ar "dj tiŽsto" "dj tiŽsto.aif">.

Posted Jun 13, 2013, 10:15 am
This member is currently offline jamesrae
Member


Member Level

Group: Moderators
Posts: 64
Joined: Dec 13, 2008

Add jamesrae to your buddy list Send an email to jamesrae Send a personal messsage to jamesrae Reply with a quote from this post Go to the top of the page

I am very sorry for the incorrect information, the ISO8859-1 fix was not part of 1.20.20 but part of our Audio Book creator.

We have added the fix to an update which you are more than welcome to use. Please contact support for a link to the update.
.........................
James Rae
Pa-software support

Posted Jun 15, 2013, 2:08 pm
This member is currently offline DJP
Newbie


Member Level

Group: Members
Posts: 3
Joined: Jun 13, 2013

Add DJP to your buddy list Send an email to DJP Reply with a quote from this post Go to the top of the page

All good now. v1.20.20b works with non-standard characters.

Thanks.

Posted Jun 17, 2013, 7:29 pm
Pages: << prev 1 next >>